Jump to content

JCE and sh404sef breaks images


Recommended Posts

Okay, fighting with this for awhile now I found some answers.

It could be one of two things

1.) Joomla SEF plugin disabled or missing. Only way I found to reinstall was to make sure the two files (sef.php and sef.xml) both exist under site/plugins/system then you need to import the SQL code. What worked for me was the .csv attached below (which worked for me but may not for you so please use at your own risk)

2.) JCE Configuration option under Cleanup - Relative URL's set to YES (needs set to NO) With it set to YES it was breaking my images but now all is lovely.

For example:

I open an article that has embedded images and instead of showing the image it shows a question mark.

http://www.mywiseguys.net/how-to/mac-os ... r-mac.html

I right click on the question mark and tell it to open in a new tab so I can see where it thinks the image is and it appears sh404SEF is adding the section and category in front of the image path (this is bad).

http://www.mywiseguys.net/how-to/mac-os ... uper_1.jpg

Actual image is located at

http://www.mywiseguys.net/images/storie ... uper_1.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...